[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Reliable internet site



On Mon, Jan 29, 2001 at 10:32:33AM +0000, ETI - KOUROUMA Aboubacar wrote:
>     Many things are clear now in my mind. I have to run OSPF between RA and RC
> for the first side, and between RC and RB for the second side.

Effectively they form one big OSPF "cloud". For example, any announcements
from RA are picked up by RC and flooded to RB automatically.

> > Now, you say that you want all traffic to 206.98.254.0/24 to go via the Telco
> > link, presumably because these machines are all within your country
> > and reached via the Telco. This is now easy to arrange: on router RA only, add
> > a static route.
> >
> > ip route 206.98.254.0 255.255.255.0 serial0
> >
> > This will be learned by the other routers via OSPF. So even if a machine on
> > Network B pings 206.98.254.1, the packet will be routed out via RC and RA.
> 
>     Okay. But what do you think about adding the same static route on RB?
>     Ip route 206.98.254.0 255.255.255.0 eth0 ! I supposed the interface Eth0 on
> RB is the one connected to RC.

There is no need to add that route. RA has the static route, and will
announce it via OSPF (because of "redistribute static subnets"), so it will
be learned by RC and RB. 'show ip route' on those routers will show it as an
'O' (OSPF) route.

By the way, static routes on ethernets need to have an explicit "next hop"
address, otherwise the router won't know where to send the packets. e.g.

  ip route 206.98.254.0 255.255.255.0 192.0.2.253     <-- correct
  ip route 206.98.254.0 255.255.255.0 eth0            <-- bad (no next-hop)

> > Then all packets from Network B to network A will be redirected to RC and
> > from there to RA.
> On RC I think the configuration will be simple like this:
> 
> ! The eth0 on RC is connected to RA and eth1 to RB
> Ip route 206.98.254.0 255.255.255.0 eth0
> Ip route 192.0.2.0 255.255.255.0 eth1

Those static routes aren't required either, because by the time you have
configured RC's eth0 and eth1 interfaces with an IP address, you will get
'connected' routes. It should go something like this:

RA:

int e0
  ip address 206.98.254.190 255.255.255.192
int s0
  description Telco link
  ip address <whatever> 255.255.255.252
  encapsulation <whatever>
router ospf 1
  passive-interface s0
  redistribute connected subnets
  redistribute static subnets
  default-information originate metric 100
ip route 0.0.0.0 0.0.0.0 s0
ip route 206.98.254.0 255.255.255.0 s0    ! whole /24 to Telco

RB:

int e0
  ip address 192.0.2.254 255.255.255.0
int s0
  description Satellite link
  ip address <whatever> 255.255.255.252
  encapsulation <whatever>
router ospf 1
  passive-interface s0
  redistribute connected subnets
  redistribute static subnets
  default-information originate metric 100
ip route 0.0.0.0 0.0.0.0 s0

RC:

int e0  
  ip address 206.98.254.189 255.255.255.192
int e1
  ip address 192.0.2.253 255.255.255.0
router ospf 1
  redistribute connected subnets


Notice that there are _no_ static routes on RC at all. But if you run
'show ip route' on RC, you should see:

C  206.98.254.128/26 via eth0           ! connected route
C  192.0.2.0/24 via eth1                ! connected route
O  206.98.254.0/24 via 206.98.254.190   ! learned via OSPF (from RA static)
O  0.0.0.0/0 via 206.98.254.190         ! learned via OSPF (from RA/RB's
   0.0.0.0/0 via 192.0.2.254            !   default-information originate)

In other words, simply setting 'ip address 206.98.254.189 255.255.255.192'
within the eth0 interface automatically adds the route to 206.98.254.128/26
via eth0; these 'C' routes will be there all the time, regardless of OSPF,
unless you actually unplug the ethernet cable.

Looking from the point of view of RB, you should see:

C  192.0.2.0/24 via eth0                ! connected (ethernet)
C  x.x.x.x/30 via serial0               ! connected (satellite link)
S  0.0.0.0/0 via serial0                ! our static defaultroute
O  206.98.254.128/26 via 192.0.2.253    ! learned from RC's connected route
O  206.98.254.0/24 via 192.0.2.253      ! learned from RA's static route

Cheers,

Brian.